为什么谷歌NPAPI插件现在无法正常运行?

以前,插件可用来为浏览器增添更多功能,不过现在,网站创建者可以通过更安全的方式,将多数这类功能默认地添加到 HTML5 中。2015 年 9 月 1 日之后,Chrome 将不再支持这些插件。

Chrome 不支持网站内容所使用的插件。

为什么 NPAPI 插件现在无法正常运行?

过去,许多插件都是使用名为 NPAPI 的旧版系统开发而成。如今,只有少量网站在使用 NPAPI 插件,因为这些插件常常会给网站带来安全风险。

为了让用户获得更安全、更快速且更稳定的 Chrome 浏览体验,2015 年 9 月 1 日我们已停止支持 NPAPI 插件。

使用 NPAPI 的插件(包括 Silverlight、Java 和 Unity)将无法正常运行。如果您想浏览使用 NPAPI 插件的网站,则需要使用其他网络浏览器。

PPAPI 插件仍会正常运行

使用更新更安全的 Pepper API (PPAPI) 系统的插件仍会正常运行,其中包括 Chrome 自带的插件(如 Adobe Flash)。Chrome 自带的 PPAPI 插件会在 Chrome 更新时一同更新,因此没有必要再安装任何额外的插件。

解决 Flash 问题

如果 Flash 不能正常工作,请尝试通过以下方案来解决该问题:

第 1 步:启用 PPAPI 插件

打开 Chrome。

在顶部的地址栏中输入 chrome://plugins 并按 Enter 键,点击详细信息。

向下滚动到“Adobe Flash Player”。

在“类型:PPAPI”下方,点击启用。

第 2 步:确保 Chrome 是最新版本

在 Chrome 上自动获得 Adobe Flash 播放器,并且这款播放器会随着 Chrome 一起更新。

第 3 步:手动更新 Adobe Flash 播放器

打开 Chrome。

在顶部的地址栏中输入 chrome://components,然后按 Enter 键。

在“pepper_flash”下,点击检查是否有更新。

使用 NPAPI 的插件(包括 Silverlight、Java 和 Unity)将无法正常运行。

 

相关经验

导读书签
书签初始化中…