XULRuner错误是由于火狐版本匹配出现了问题,常见于非官方编译发行的火狐浏览器版本,以下两种解决方案供参考

错误重现

XULRuner错误是由于火狐版本匹配出现了问题,常见于非官方编译发行的firefox火狐浏览器版本。

XULRunner Error: Platform version '47.0.2' is not compatible with 
minVersion >= 43.0.1
maxVersion <= 43.0.1
火狐浏览器:关于XULRuner错误的解决办法-久久经验网

火狐XULRunner错误警告

这个错误间歇性提示,上图中的版本号根据不同版本的firefox浏览器提示也会不同,因此仅供参考。

解决办法

建议重新安装官方提供的火狐浏览器。如果不方便卸载重装(常见于业务系统,部署了插件等),可参考本文提供的经验去配置火狐浏览器。

在火狐的安装目录找到配置文件application.ini,用记事本打开后搜索以下语句(如果找不到的话,可以搜索minversion)将:
minVersion=43.0.1
maxVersion=43.0.1里的minVersion的数值改大点,不小于错误提示里的数值即可: minVersion=47.0.2
maxVersion=43.0.1

修改保存后重启浏览器,如果错误依旧则建议重新安装firefox火狐浏览器(官方网站下载)。

火狐历史版本一览:http://ftp.mozilla.org/pub/firefox/releases/